我依照:
http://www.debian.org/doc/manuals/reference/ch-woody.zh-tw.html

的方式將我的 server 由 stable 升級到 testing。

目前看起來都還 ok。
apache,Bind9,php,mysql,postfix,ftp,and ssh 都有在正常運作。
下這指令:

dpkg -l | grep woody


結果是:

rc  exim           3.35-1woody2   An MTA (Mail Transport Agent)
ii  kernel-source- 2.4.19-4.woody Linux kernel source for version 2.4.19
ii  libasn1-5-heim 0.4e-7.woody.9 Libraries for Heimdal Kerberos
ii  libcomerr1-hei 0.4e-7.woody.9 Libraries for Heimdal Kerberos
ii  libdns5        9.2.1-2.woody. DNS Shared Library used by BIND
ii  libisc4        9.2.1-2.woody. ISC Shared Library used by BIND
rc  libmagick5     5.4.4.5-1woody Image manipulation library (free version).
rc  libroken9-heim 0.4e-7.woody.9 Libraries for Heimdal Kerberos
ii  libsasl-gssapi 1.5.24-15woody Pluggable Authentication Modules for SASL -
ii  libtiff3g      3.5.5-6.woody5 Tag Image File Format library
rc  nfs-common     1.0-2woody1    NFS support files common to client and serve
rc  nfs-kernel-ser 1.0-2woody1    Kernel NFS server support
rc  qpopper        4.0.4-2.woody. Enhanced Post Office Protocol server (POP3).

ii 的才是有安裝,rc 是已經砍掉的了,但設定檔還在,可以進一步purge。
剩下的 ii 是因為 sarge 已經沒有這些玩意兒了,用不到的就可以砍掉。